Nach Update auf Php 5.3 5.4 oder 5.5 erscheint dieser Fehler?

 

Deprecated: Function eregi() is deprecated in language.php on line 97

 

Dafür gibt es eine Lösung. Wenn Sie ein update Ihrer Php Versionen gemacht haben oder Ihr Hoster hat dieses Update durchgeführt, kann es sein, dass diese Fehlermeldung erscheint.

 

Warum werden Updates gemacht?

In der Technik geht es ständig weiter. Neuere Versionen von PHP erlauben schnellere Skripte, sicherere Skripte als alte Versionen.

Beispiel: Ein Kunde von uns, der jahrelang mit einem CMS System (zum Selbstpflegen) nicht upgedatet hatte, hatte eine unschöne Weiterleitung. Nach einer Minute auf der Seite wurde man weitergeleitet auf eine Seite, die sehr schlecht für das Renomee des Kunden war. Da keine Updates gemacht wurden, war es für einen Hacker ein leichtes, den Homepageserver zu infizieren.